Microsoft Excel

Herbers Excel/VBA-Archiv

alle Tabellenblattnamen auslesen | Herbers Excel-Forum


Betrifft: alle Tabellenblattnamen auslesen von: lisa
Geschrieben am: 19.05.2009 14:36:36

Hallo

Mit dieser Formel bekomme ich den Tabellblattnamen angezeigt.

=ERSETZEN(ZELLE("Dateiname");1;FINDEN("]";ZELLE("Dateiname"));"")

Was muss ich tun, dass ich alle Tabellenblattnamen meiner Mappe In Tabelle1 in Spalte a angezeigt bekomme?

Hat hier jemand eine Idee?

  

Betrifft: AW: alle Tabellenblattnamen auslesen von: ede
Geschrieben am: 19.05.2009 14:42:47

Hallo Lisa,
per vba hier ein kleiner ansatz

Sub sheetNamen()
For i = 1 To Sheets.Count
    Sheets(1).Cells(i, 1) = Sheets(i).Name
Next i
End Sub



gruss


  

Betrifft: AW: alle Tabellenblattnamen auslesen von: lisa
Geschrieben am: 19.05.2009 14:47:25

Hallo

Danke für die schnelle Antwort

Das ist sehr gut, aber wie bekomme ich es so hin, dass die Tabellen die nach Ausführung des Macros hinzugefügt werden, ohne das Macro noch einmal zu betätigen, aufgelistet werden?

Noch eine Idee?

Gruß Lisa


  

Betrifft: AW: alle Tabellenblattnamen auslesen von: Hajo_Zi
Geschrieben am: 19.05.2009 14:45:43

Hallo Lisa,


vorhandene Tabellen

 ABCDEFG
2Übersicht           
3vorhandene Tabellen           
412.10.2003Oktoberfest - Kunde Mustermann    50018:0023:00
517.04.2003Maifest - Jungesellenverein    10014:0022:00
6             
7  Hi Holger,         
8             
9  hatte diese Frage auch grad in einem anderen Forum (anderer Fragesteller) so beantwortet:         
10             
11  Einfügen -> Namen -> Definieren/Festlegen, Name: x         
12  bezieht sich auf:         
13  =ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())         
14             
15  In irgendeine Zelle jetzt diese Formel und runterkopieren:         
16  =WENN(ZEILEN($1:1)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:1));FINDEN("]";INDEX(x;ZEILEN($1:1)))+1;31))         
17             
18  Grüße Boris         
19             
20             
21  Formel runter ziehen falls Mehr Tabellen         

verwendete Formeln
Zelle Formel
A2 =WENN(ZEILEN($1:1)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:1));FINDEN("]";INDEX(x;ZEILEN($1:1)))+1;31))
A3 =WENN(ZEILEN($1:2)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:2));FINDEN("]";INDEX(x;ZEILEN($1:2)))+1;31))
A4 =WENN(ZEILEN($1:3)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:3));FINDEN("]";INDEX(x;ZEILEN($1:3)))+1;31))
B4 =WENN(ISTFEHLER(INDIREKT(A4&"!B4:D4"));"";INDIREKT(A4&"!B4:D4"))
E4 =WENN(ISTFEHLER(INDIREKT(A4&"!E4"));"";INDIREKT(A4&"!E4"))
F4 =WENN(ISTFEHLER(INDIREKT(A4&"!F4"));"";INDIREKT(A4&"!F4"))
G4 =WENN(ISTFEHLER(INDIREKT(A4&"!G4"));"";INDIREKT(A4&"!G4"))
A5 =WENN(ZEILEN($1:4)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:4));FINDEN("]";INDEX(x;ZEILEN($1:4)))+1;31))
B5 =WENN(ISTFEHLER(INDIREKT(A5&"!B4:D4"));"";INDIREKT(A5&"!B4:D4"))
E5 =WENN(ISTFEHLER(INDIREKT(A5&"!E4"));"";INDIREKT(A5&"!E4"))
F5 =WENN(ISTFEHLER(INDIREKT(A5&"!F4"));"";INDIREKT(A5&"!F4"))
G5 =WENN(ISTFEHLER(INDIREKT(A5&"!G4"));"";INDIREKT(A5&"!G4"))
A6 =WENN(ZEILEN($1:5)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:5));FINDEN("]";INDEX(x;ZEILEN($1:5)))+1;31))
B6 =WENN(ISTFEHLER(INDIREKT(A6&"!B4:D4"));"";INDIREKT(A6&"!B4:D4"))
C6 =WENN(ISTFEHLER(INDIREKT(A6&"!E4"));"";INDIREKT(A6&"!E4"))
D6 =WENN(ISTFEHLER(INDIREKT(A6&"!F4"));"";INDIREKT(A6&"!F4"))
E6 =WENN(ISTFEHLER(INDIREKT(A6&"!G4"));"";INDIREKT(A6&"!G4"))
D7 =WENN(ISTFEHLER(INDIREKT(A7&"!F4"));"";INDIREKT(A7&"!F4"))
E7 =WENN(ISTFEHLER(INDIREKT(A7&"!G4"));"";INDIREKT(A7&"!G4"))
D8 =WENN(ISTFEHLER(INDIREKT(A8&"!F4"));"";INDIREKT(A8&"!F4"))
E8 =WENN(ISTFEHLER(INDIREKT(A8&"!G4"));"";INDIREKT(A8&"!G4"))
D9 =WENN(ISTFEHLER(INDIREKT(A9&"!F4"));"";INDIREKT(A9&"!F4"))
E9 =WENN(ISTFEHLER(INDIREKT(A9&"!G4"));"";INDIREKT(A9&"!G4"))
D10 =WENN(ISTFEHLER(INDIREKT(A10&"!F4"));"";INDIREKT(A10&"!F4"))
E10 =WENN(ISTFEHLER(INDIREKT(A10&"!G4"));"";INDIREKT(A10&"!G4"))
D11 =WENN(ISTFEHLER(INDIREKT(A11&"!F4"));"";INDIREKT(A11&"!F4"))
E11 =WENN(ISTFEHLER(INDIREKT(A11&"!G4"));"";INDIREKT(A11&"!G4"))
D12 =WENN(ISTFEHLER(INDIREKT(A12&"!F4"));"";INDIREKT(A12&"!F4"))
E12 =WENN(ISTFEHLER(INDIREKT(A12&"!G4"));"";INDIREKT(A12&"!G4"))
D13 =WENN(ISTFEHLER(INDIREKT(A13&"!F4"));"";INDIREKT(A13&"!F4"))
E13 =WENN(ISTFEHLER(INDIREKT(A13&"!G4"));"";INDIREKT(A13&"!G4"))
D14 =WENN(ISTFEHLER(INDIREKT(A14&"!F4"));"";INDIREKT(A14&"!F4"))
E14 =WENN(ISTFEHLER(INDIREKT(A14&"!G4"));"";INDIREKT(A14&"!G4"))
D15 =WENN(ISTFEHLER(INDIREKT(A15&"!F4"));"";INDIREKT(A15&"!F4"))
E15 =WENN(ISTFEHLER(INDIREKT(A15&"!G4"));"";INDIREKT(A15&"!G4"))
D16 =WENN(ISTFEHLER(INDIREKT(A16&"!F4"));"";INDIREKT(A16&"!F4"))
E16 =WENN(ISTFEHLER(INDIREKT(A16&"!G4"));"";INDIREKT(A16&"!G4"))
D17 =WENN(ISTFEHLER(INDIREKT(A17&"!F4"));"";INDIREKT(A17&"!F4"))
E17 =WENN(ISTFEHLER(INDIREKT(A17&"!G4"));"";INDIREKT(A17&"!G4"))
D18 =WENN(ISTFEHLER(INDIREKT(A18&"!F4"));"";INDIREKT(A18&"!F4"))
E18 =WENN(ISTFEHLER(INDIREKT(A18&"!G4"));"";INDIREKT(A18&"!G4"))
A19 =WENN(ZEILEN($1:18)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:18));FINDEN("]";INDEX(x;ZEILEN($1:18)))+1;31))
B19 =WENN(ISTFEHLER(INDIREKT(A19&"!B4:D4"));"";INDIREKT(A19&"!B4:D4"))
C19 =WENN(ISTFEHLER(INDIREKT(A19&"!E4"));"";INDIREKT(A19&"!E4"))
D19 =WENN(ISTFEHLER(INDIREKT(A19&"!F4"));"";INDIREKT(A19&"!F4"))
E19 =WENN(ISTFEHLER(INDIREKT(A19&"!G4"));"";INDIREKT(A19&"!G4"))
A20 =WENN(ZEILEN($1:19)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:19));FINDEN("]";INDEX(x;ZEILEN($1:19)))+1;31))
B20 =WENN(ISTFEHLER(INDIREKT(A20&"!B4:D4"));"";INDIREKT(A20&"!B4:D4"))
C20 =WENN(ISTFEHLER(INDIREKT(A20&"!E4"));"";INDIREKT(A20&"!E4"))
D20 =WENN(ISTFEHLER(INDIREKT(A20&"!F4"));"";INDIREKT(A20&"!F4"))
E20 =WENN(ISTFEHLER(INDIREKT(A20&"!G4"));"";INDIREKT(A20&"!G4"))
A21 =WENN(ZEILEN($1:20)>VERGLEICH("";x;-1);"";TEIL(INDEX(x;ZEILEN($1:20));FINDEN("]";INDEX(x;ZEILEN($1:20)))+1;31))
C21 =WENN(ISTFEHLER(INDIREKT(A21&"!E4"));"";INDIREKT(A21&"!E4"))
D21 =WENN(ISTFEHLER(INDIREKT(A21&"!F4"));"";INDIREKT(A21&"!F4"))
E21 =WENN(ISTFEHLER(INDIREKT(A21&"!G4"));"";INDIREKT(A21&"!G4"))

definierte Namen
Name Bezieht sich auf
x =ARBEITSMAPPE.ZUORDNEN(1+0*JETZT())

Tabellendarstellung in Foren Version 1.5


GrußformelHomepage


  

Betrifft: AW: alle Tabellenblattnamen auslesen von: lisa
Geschrieben am: 20.05.2009 09:08:51

Hallo

Danke für die Hilfe
Ich konnte mich nicht mehr melden, da es gestern irgendwelche Probleme in diesem Forum gab.
Ich konnte keine Antworten mehr aufrufen.
War wohl offline das Forum.

Nun ja danke für die Hilfe und es klappt wie gewünscht.

Gruß Lisa


Beiträge aus den Excel-Beispielen zum Thema "alle Tabellenblattnamen auslesen "