Microsoft Excel

Herbers Excel/VBA-Archiv

Summewenn - Addition verschiedener Zellen | Herbers Excel-Forum


Betrifft: Summewenn - Addition verschiedener Zellen von: Dietmar aus Aachen
Geschrieben am: 23.01.2010 14:37:11

Guten Morgen zusammen,

Eigentlich suche ich eine Summewenn-Funktion, die einen zusammenhängenden Bereich prüft,
dann aber Einzelzellen summiert. Kann da leider nichts finden.

Habe dann folgendes versucht, funktioniert aber auch nicht. Jemand eine Ahnung?

{=SUMME(($A$1:$E$1=1)*((A3)+(C3)+(E3)))}

Folgende Vorgabe:

Der zu pürfende Bereich in Zeile 1 ist wie folgt belegt:
A1------C1------ E1
1-------leer------1

Dann die eigetragenen Wert in Zeile 3
A3------C3-------E3
2 -------2---------2

Mit obiger Formel lautet das Ergebnis 12; Wieso? Es müsste doch 4 herauskommen.

Jemand eine Ahnung wie es funktionieren könnte.

Vielen Dank!

Dietmar aus Aachen

  

Betrifft: =SUMMEWENN(A1:E1;1;A3:E3) oT. von: Tino
Geschrieben am: 23.01.2010 14:42:31




  

Betrifft: Danke, mein Problem löst es aber nicht von: Dietmar aus Aachen
Geschrieben am: 23.01.2010 14:53:21

Hallo Tino,

Danke, aber das löst nicht mein Problem, weil in Zeile 3 nur die angegebenen Werte addiert werden sollen.
In den Zelle B3 und D3 stehen andere Werte, die bei der Bereichsangabe A3:E3 auch summiert würden; und das soll eben nicht sein (hätte ich deutlicher sagen sollen).

Ich bin sehr gespannt.

Dietmar aus Aachen


  

Betrifft: vielleicht so von: Tino
Geschrieben am: 23.01.2010 15:19:23

Hallo,

 ABCDE
111 31
2     
322222
4     
54    

Formeln der Tabelle
ZelleFormel
A5{=SUMME(WENN((REST(SPALTE($A$1:$E$1); 2)=1)*($A$1:$E$1=1); $A$3:$E$3))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Gruß Tino


  

Betrifft: AW: Summewenn - Addition verschiedener Zellen von: And
Geschrieben am: 23.01.2010 14:43:43

Hallo,

=SUMMENPRODUKT(($A$1:$E$1=1)*(A3:E3))

Gruß Andreas


  

Betrifft: Yesss das war es !!! von: Dietmar aus Aachen
Geschrieben am: 23.01.2010 15:38:19

Vielen Dank!

So etwas hatte ich auch ganz schwach im Hinterkopf.
Aber es ist eben ein Unterschied, ob man es nur passiv weiß oder aktiv anbringen kann.

So, jetzt kann ich weitermachen in meiner Datei!! :-)

Gruß
Dietmar aus Aachen


  

Betrifft: ist doch gleich mit Summewenn ;-) von: Tino
Geschrieben am: 23.01.2010 15:42:01

Hallo,
diese Formel bringt das gleiche Ergebnis wie Summewenn!

Gruß Tino


  

Betrifft: Summenprodukt ist m.E. nicht gleich Summewenn von: Dietmar aus Aachen
Geschrieben am: 23.01.2010 15:45:53

Hallo Tino,

ich meine nein, weil Summewenn mir nicht erlaubt im Ergebnisbereich zwischen den zu summierenden Zellen andere Zellen mit Werten zu belegen, die NICHT summiert werden sollen.

Gruß
Dietmar aus Aachen


  

Betrifft: beide Formeln bringen das gleiche Ergebnis. von: Tino
Geschrieben am: 23.01.2010 16:05:19

Hallo,

 ABCDE
111 31
2     
322222
4     
56    
66    

Formeln der Tabelle
ZelleFormel
A5=SUMMEWENN(A1:E1;1;A3:E3)
A6=SUMMENPRODUKT((A1:E1=1)*(A3:E3))


Gruß Tino


  

Betrifft: Oh! Du hast doch! recht! ... von: Dietmar aus Aachen
Geschrieben am: 23.01.2010 17:20:06

Hallo Tino,

und jetzt frage ich mich, warum ich mir das Leben so schwer gemacht habe ???
Ich kanns Dir nicht mehr sagen. Irgendwie muss ich da einen Knoten im Kopf gehabt haben.

Danke Dir ganz herzlich!

Liebe Grüße aus Aachen
Dietmar


  

Betrifft: AW: Summewenn - Addition verschiedener Zellen von: Daniel
Geschrieben am: 23.01.2010 14:46:18

Hi

du musst die Summe einfach so bilden:
=A3*($A$1=1)+C3*($C$1=1)+E3*($E$1=1)

oder einfacher, wenn in Zeile 1 nur 1 oder leer vorkommen:
=A3*$A$1+C3*$C$1+E3*$E$1

Deine Matrixformel Summiert immer die Zellen A3-C3-E3 auf, wenn für eine Zelle aus A1-E1 die Bedingung =1 erfüllt ist.
Dies ist 2x der fall (A und E), also wird 2x die Sumbbe von A3-E3 aufsummiert.
und da kommt halt 12 raus, denn die Summe A3-E3 ist 6 und das ganze 2x

Gruß. Daniel


  

Betrifft: Danke ich habs jetzt ... von: Dietmar aus Aachen
Geschrieben am: 23.01.2010 15:42:13

Hallo Daniel,

Deine Lösung finde ich auch sehr interessant, werde sie mir mal weglegen.
Hatte gerade folgende Antwort erhalten:

=SUMMENPRODUKT(($A$1:$E$1=1)*(A3:E3))

Werde damit zunächst einmal weitermachen, weil ich so etwas auch schwach in Erinnerung hatte.


Liebe Grüße
Dietmar aus Aachen


Beiträge aus den Excel-Beispielen zum Thema "Summewenn - Addition verschiedener Zellen"