Herbers Excel-Forum - das Archiv

Name des Tabellenblattes eines ben. Bereichs

Bild

Betrifft: Name des Tabellenblattes eines ben. Bereichs
von: Arthur

Geschrieben am: 22.12.2006 11:59:38
Hi together.
Die hoffentlich letzte Frage für heute:
Gibt es noch eine Formel, bei der der Name des Tabellenblattes als Ergebnis herauskommt, in dem sich ein benannter Bereich befindet?
Gruß
Arthur
Bild

Betrifft: AW: Name des Tabellenblattes eines ben. Bereichs
von: Daniel Eisert

Geschrieben am: 22.12.2006 12:38:30
Hallo
obs das als Formel gibt, weiß ich nicht, aber in VBA gibts folgende Möglichkeit, sich den Blattnamen des Bereichs als String ausgeben zu lassen:
range("Bereichsname").parent.name
wenn du es als Formel brauchst und nichts anderes Findest, dann halt ne UDF draus machen.
Gruß, Daniel
Bild

Betrifft: AW: Name des Tabellenblattes eines ben. Bereichs
von: Erich G.

Geschrieben am: 22.12.2006 13:11:48
Hallo Arthur,
vielleicht hilft dir das weiter:
 BCD
1Bezug=NAMEN.ZUORDNEN([Mappe2]Tabelle2!ZS(-1))Tabelle2
2eeee=[Mappe2]Tabelle1!Z8S1:Z10S1Tabelle1
3Namen=NAMEN(;3;"*")#WERT!
4safsdf=[Mappe2]Tabelle2!Z6S1Tabelle2
5xyz=[Mappe2]Tabelle1!Z5S2:Z8S2Tabelle1

Formeln der Tabelle
ZelleFormel
B1=WENN(ZEILE()>ANZAHL2(Namen);"";INDEX(Namen;ZEILE()))
C1=WENN(B1<>"";Bezug;"")
D1=TEIL(C1;FINDEN("]";C1)+1;FINDEN("!";C1)-FINDEN("]";C1)-1)
B2=WENN(ZEILE()>ANZAHL2(Namen);"";INDEX(Namen;ZEILE()))
C2=WENN(B2<>"";Bezug;"")
D2=TEIL(C2;FINDEN("]";C2)+1;FINDEN("!";C2)-FINDEN("]";C2)-1)
Namen in Formeln
ZelleNameBezieht sich auf
B1Namen=NAMEN(;3;"*")
C1Bezug=NAMEN.ZUORDNEN(Tabelle2!B1)
C1Namen=NAMEN(;3;"*")
B2Namen=NAMEN(;3;"*")
C2Bezug=NAMEN.ZUORDNEN(Tabelle2!B2)
C2Namen=NAMEN(;3;"*")

( unter Verwendung von http://www.excelformeln.de/formeln.html?welcher=256 )
Rückmeldung wäre nett! - Erich aus Kamp-Lintfort wünscht euch schöne Feiertage!
 Bild
Excel-Beispiele zum Thema "Name des Tabellenblattes eines ben. Bereichs"
Mehrbereichsauswahl auf eine Seite drucken. Spalten einer Mehrbereichsauswahl ausblenden.
Den selben Bereichsnamen in mehreren Tabellenblättern Serie von Bereichsnamenteilen einer Arbeitsmappe ändern
Bereichsnamen ermitteln und als Kommentare anzeigen Bereichsnamen in UserForm-ListBox auflisten und editieren
Zugriff auf Zellen unter Verwendung eines Bereichsnamens Mit VBA-Routine Bereichsnamen festlegen und ändern
Druckbereichsauswahl über CheckBoxes