"Zählenwenn" eine Bedingung erfüllt ist



Excel-Version: 8.0 (Office 97)
nach unten

Betrifft: "Zählenwenn" eine Bedingung erfüllt ist
von: Stefan
Geschrieben am: 02.07.2002 - 08:24:51

Hallo, ich habe folgendes Problem:
Ich möchte eine bestimmte Spalte zusammenzählen, wenn in der selben Zeile zwei Bedingungen erfüllt sind. Aber ich scheitere leider immer wieder an der zweiten Bedingung.

Beispiel:
.......A.........B........C....
1...XYZ...DEF...100...
2...XYZ...STU...10....
3...XYZ...DEF...100...

In diesem Fall, suche ich ein Formel, die die Spalte C zusammenzählt, wenn in A=XYZ und in B=DEF steht. In diesem Fall sollte dann als Ergebnis 200 erscheinen.

Vielen Dank.
mfg Stefan



nach oben   nach unten

Re: "Zählenwenn" eine Bedingung erfüllt ist
von: Berai
Geschrieben am: 02.07.2002 - 08:29:34

Hallo Stefan,


=SUMMENPRODUKT((A1:A1000="XYZ")*(B1:B1000="DEF")*C1:C1000)

Gruß
Rainer

nach oben   nach unten

Re: "Zählenwenn" eine Bedingung erfüllt ist
von: Heinz
Geschrieben am: 02.07.2002 - 08:31:42

Hallo Stefan,

in einem Schritt geht das nicht. Summewenn kann meines Wissens keine zwei Bedingungen prüfen. deshalb mein Vorschlag:

Eine Hilfsspalte mit einer WENN(UND( ...)...) und dann Summewenn auf die erfülllte Bedingung in der Hilfsspalte.

Formeln ab D1: =Wenn(und(A1=xyz;b1=DEF);"érfüllt";"") kopieren

und in E1: =summewenn(D1:d500;"Erfüllt";c1:c500)

Gruß Heinz

nach oben   nach unten

Re: "Zählenwenn" eine Bedingung erfüllt ist
von: Stefan
Geschrieben am: 02.07.2002 - 08:33:47

Vielen Dank, hat funktioniert :-)
 nach oben

Beiträge aus den Excel-Beispielen zum Thema ""Zählenwenn" eine Bedingung erfüllt ist"