Microsoft Excel

Herbers Excel/VBA-Archiv

Tabellenname in Formel aus Zelle beziehen

Betrifft: Tabellenname in Formel aus Zelle beziehen
von: Mike
Geschrieben am: 16.04.2003 - 17:55:17

hallo

ist es möglich, und wenn ja wie, den tabellennamen der in einer formel verwendet wir aus einer zelle zu beziehen

z.b: in zelle A1 steht Wien oder Graz oder Linz oder.....

die formel lautet:
=WENN($A4="";"";SUMMEWENN(Wien!$D:$D;$A4;Wien!$G:$G))

nun möchte ich diesen fixen tabellennamen (Wien) variabel aus zelle A1 beziehen.

danke mike

  

Re: Tabellenname in Formel aus Zelle beziehen
von: Rolf, Lgh.
Geschrieben am: 16.04.2003 - 17:59:59

Hallo Mike,
schau Dir mal die Funktion INDIREKT an.
Gruß Rolf

  

Re: Tabellenname in Formel aus Zelle beziehen
von: Ramses
Geschrieben am: 16.04.2003 - 18:02:42

Hallo Mike

ja das geht

=WENN($A4="";"";SUMMEWENN(INDIREKT(A1&"!$D:$D");$A4;INDIREKT(A1&"!$G:$G")))

Gruss Rainer


  

Re: Tabellenname in Formel aus Zelle beziehen
von: mike
Geschrieben am: 16.04.2003 - 18:07:30

das checkt ich nicht. wie soll ich das in die formel einbauen??

mike

  

funktioniert - danke
von: mike
Geschrieben am: 16.04.2003 - 18:09:24

ja das geht!!

vielen dank
mike

 

Beiträge aus den Excel-Beispielen zum Thema "Tabellenname in Formel aus Zelle beziehen"