Pivot-Problem: berechnetes Feld

Bild

Betrifft: Pivot-Problem: berechnetes Feld von: Natascha Seidel
Geschrieben am: 19.03.2005 16:42:52

Hallo zusammen,

ich möchte in einer Pivot-Tabelle ein berechnetes Feld nutzen, in dem ich 2 Spalten aus den zugrunde liegenden Daten multiplizieren möchte.
Definition des berechneten Feldes kein Problem. ABER wenn ich jetzt dieses Feld in den Datenbereich hinzufüge und mir die Summe(berechnetes Feld) anzeigen lasse, dann sieht die Berechnung SO aus, dass Excel erst die Spalte A SUMMIERT und DANN mit der SUMMIERTEN Spalte B MULTIPLIZIERT. Ich möchte aber, dass natürlich erst zeilenweise die Spalten multipliziert werden und DANN die Summe angezeigt wird. Was mache ich falsch?

Würde mich über Hinweise sehr freuen!

Bild


Betrifft: AW: Pivot-Problem: berechnetes Feld von: ransi
Geschrieben am: 19.03.2005 17:01:07

hallo natascha

Pivot ist nicht meine welt.
Null ahnung.
aber schau mal hier:
ein paar berechnungen mit summe() und summenprodukt().
vieleicht hilfts dir ja weiter.
 
 ABC
111028700
222028700
333028700
4440441000
5550 
6660 
7770 
8880 
9990 
1010100 
1111110 
1212120 
1313130 
1414140 
1515150 
1616160 
1717170 
1818180 
1919190 
2020200 
Formeln der Tabelle
C1 : =SUMMENPRODUKT(A1:A20;B1:B20)
C2 : =SUMMENPRODUKT((A1:A20)*(B1:B20))
C3 : {=SUMME((A1:A20)*(B1:B20))}
C4 : =SUMME(A1:A20)*SUMME(B1:B20)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

ransi


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Makro für mehr als drei bedingte Formatierungen"