Formel ausführen, bis Wert sich ändert...

Bild

Betrifft: Formel ausführen, bis Wert sich ändert...
von: Michael
Geschrieben am: 18.04.2005 09:27:43
https://www.herber.de/bbs/user/21274.xls

Hallo!
Habe mal wieder ein Problem!
Also: Ich möchte eine Formel so lange ausführen lassen, bis ein bestimmter Wert sich ändert (im Beispiel Art-Gruppe), und zwar soll dabei für alle Werte in diesem Bereich ein Durchschnittswert ermittelt werden, also z.B. für die Art.Gruppe 1037 (10+12) : 2, für 2101 (24+26) : 2 usw.
Ist das möglich?
Danke schon jetzt!
Michael

Bild

Betrifft: AW: Formel ausführen, bis Wert sich ändert...
von: MichaV
Geschrieben am: 18.04.2005 09:38:59
Hi,
fast alles ist Möglich. Es ist aber m.E. auch notwendig, daß Du Dein Problem noch ein bischen genauer beschreibst. Welche Formel meinst Du, was hat der Durchschnittswert damit zu tun?
Gruß- Micha
Bild

Betrifft: AW: Formel ausführen, bis Wert sich ändert...
von: Michael
Geschrieben am: 18.04.2005 10:00:43
Ja, da hast du recht.
Also. Mit der "Formel" meine ich die Formel, die mir das gewünschte ausrechnet, also in diesem Fall den Durchschnittswert z.B der Durchschnitts-Preise (letzte Spalte) einer Art-Gruppe.
Die Formel (oder das Makro) soll also quasi folgendes machen:
Sie soll die Durch.Preise einer Art.Gruppe summieren und durch die Anzahl teilen, um dann dasselbe für die nächste Art-Gruppe zu tun.
Im Bsp. würde sie also Zeile 2+3 als eine Gruppe erkennen, summieren und teilen, danach Zeile 4, dann Zeile 5-12 usw.
Ist es jetzt klarer geworden? :-)
Gruß
Michaeö
Bild

Betrifft: AW: Formel ausführen, bis Wert sich ändert...
von: MichaV
Geschrieben am: 18.04.2005 10:36:19
Hi,
mit folgender Formel kannst Du die D-Preise z.B: aus Spalte H für jede Gruppe ermitteln:
=SUMMEWENN(D:D;D2;H:H)/ZÄHLENWENN(D:D;D2)
Wenn Du noch eine Tabelle brauchst, die Dir alle vorhandenen Gruppen auflistet, dann http://www.excelformeln.de/formeln.html?welcher=194
... odeer schau gleich hier: https://www.herber.de/bbs/user/21277.xls
Gruß- Micha
PS: Rückmeldung wäre nett
Bild

Betrifft: AW: Formel ausführen, bis Wert sich ändert...
von: Peter W
Geschrieben am: 18.04.2005 10:36:45
Servus,
dann nimm doch einfach ne Summewenn-Formel und Teil Sie durch ne Zählenwenn-Formel.
Ergibt denn Mittelwert eines bestimmten Suchkriteriums.
Oder versteh ich auch was falsch?
MfG
Peter
Bild

Betrifft: AW: Formel ausführen, bis Wert sich ändert...
von: Michael
Geschrieben am: 18.04.2005 11:20:49
Einfach ist gut! :-)
Ich habs jetzt, danke euch beiden! Ihr habt mir sehr geholfen!
Gruß
Michael
Bild

Betrifft: gerne o.t.
von: Peter W
Geschrieben am: 18.04.2005 12:36:26
o.t.
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formel ausführen, bis Wert sich ändert..."