Microsoft Excel

Herbers Excel/VBA-Archiv

SUMMEWENN verknüpfen

    Betrifft: SUMMEWENN verknüpfen von: Basti
    Geschrieben am: 01.09.2003 10:38:28

    Hallo,

    ich muss zwei SUMMEWENN-Formeln verknüpfen, nur so klappts leider net:
    =SUMMEWENN(UND($A$42:$A$65536;"=06";$Q$42:$Q$65536)($A$42:$A$65536;"=06";$R$42:$R$65536))

    erreicht werden soll, dass er wenn in A 06 steht, dann soll er das in Spalte Q und das in Spalte R summieren.

    Wie bieg ich das hin?

    danke und grüße,
    basti

      


    Betrifft: Zusatz... von: Basti
    Geschrieben am: 01.09.2003 10:46:17

    außerdem muss dann noch folgendes hinbiegen:

    =WENN($D7>=4;1;WENN($D7=0;" ";WENN($D7<4;0,5)))

    diese formel muss nicht nur die D-Spalte abfangen, sondern auch genauso die E-Spalte,einfach mit UND verknüpfen oder was?

    danke und noch mehr grüße,
    sebastian


      


    Betrifft: AW: Zusatz... von: Panicman
    Geschrieben am: 01.09.2003 10:52:44

    Hallo Basti

    viele Wege führn nach ROM

    =SUMMEWENN($A$1:$A$6;6;Q$1:Q$6)+SUMMEWENN($A$1:$A$6;6;R$1:R$6)
    {=SUMME(WENN($A$1:$A$6="06";Q$1:R$6))} Array-Formel (STRG-SHIFT-ENTER)
    =SUMMENPRODUKT(($A$1:$A$6="06")*((Q1:Q6)+(R1:R6)))

    such dir eine aus

    Gruß
    Holger


      


    Betrifft: AW zum Zusatz von: sergiesam
    Geschrieben am: 01.09.2003 10:55:43

    Hi,

    zu 1)
    mit Und verknüpfst du Bedingungen. Hier brauchst du nur die Addition:
    =Summewenn($A$42:$A$65536;"=06";$Q$42:$Q$65536) + Summewenn($A$42:$A$65536;"=06";$R$42:$R$65536)

    zu 2)
    stimmt mit UND verknüpfen... und du kannst die Wenn auch noch vereinfachen:
    Wenn(x>=4;1;wenn(x=0;"";0,5)) ... du brauchst nicht mehr auf <4 abfragen, denn es bleibt nichts anderes über.

    Also:
    =WENN(UND($D7>=4;$E7>=4);1;WENN(UND($D7=0;$E7=0);"";0,5))

    Gruß aus Linz,
    sam


      


    Betrifft: Danke an euch beide und noch was... von: Basti
    Geschrieben am: 01.09.2003 11:07:32

    wie gesagt: danke erst mal.

    nun noch ne kleine sache: hab noch eine summe:
    =SUMME(F6:F36)

    die soll aber nur summieren, wenn das nebenstehende feld in e nicht leer ist. also quasi
    in E6 steht 5 und E7 nichts, in F6 steht 1 und F7 2, dann soll in meiner Summe nur die 1 summiert werden:
    E F Summe = 1
    5 1
    " " 2


      


    Betrifft: AW: Danke an euch beide und noch was... von: Panicman
    Geschrieben am: 01.09.2003 11:13:05

    Hallo Basti

    versuchs hiermit
    =SUMMEWENN(E1:E7;"<>"&"";F1:F7)

    bei mit ist "nichts" = "". Mußt du evtl. anpassen

    Gruß
    Holger


      


    Betrifft: neee. leider noch nicht von: basti
    Geschrieben am: 01.09.2003 11:26:42

    klappt leider nicht, kommt beides mal dasselbe raus.

    tabelle sieht so aus:

    gesamt




    4,00 1,0
    1,00
    2,00 0,5

    9,00 1,0










    fakt. Inland 2,50
    fakt. Ausland 2,50


    verstehst du, was ich meine? einmal müsste ja 2 rauskommen und ein mal 0,5...

    grüße und danke.







      


    Betrifft: Ne, verstehe ich nicht !!! von: Panicman
    Geschrieben am: 01.09.2003 11:49:37

    Hallo Basti,

    beschreib mal dei GANZES Problem. Bei deiner 2.Anfrage war nicht zu erkennen, das du noch aufteilen willst nach Inland und Ausland.

    Wenn du eine Summewenn() mit mehreren Bedingungen brauchst, dann erkläre das mal ausführlich

    Gruß
    Holger


      


    Betrifft: AW: Ne, verstehe ich nicht !!! von: basti
    Geschrieben am: 01.09.2003 11:53:34

    hi,

    habe schon ne lösung gefunden, es reicht mir einfach folgendes:
    =SUMMEWENN(D6:D36;">0";F6:F36)
    bzw.
    =SUMMEWENN(E6:E36;">0";F6:F36)

    das dürfte keine probleme geben. danke dir trotzdem,
    sebastian


     

    Beiträge aus den Excel-Beispielen zum Thema " SUMMEWENN verknüpfen"