Zählenwenn in Kombi mit Summeprdukt

Bild

Betrifft: Zählenwenn in Kombi mit Summeprdukt
von: Guido
Geschrieben am: 25.04.2005 11:25:59
Hallo Experten,
den ganzen Früh versuche ich ohne Eure weitere Hilfe folgende Formel zu kreieren: Es soll nur gezählt werden, wenn in Zeile G2:G5 die Postleitzahl >= 74000 UND in Zeile C2:C5 die Ziffern 6+7 des Aktenzeichens >40 ist. Das wollte ich so erreichen:

{=WENN((ZÄHLENWENN('[Statistik-BH.xls]Berufshilfe'!$G$2:$G$5;">="&74000))*SUMMENPRODUKT((TEIL('[Statistik-BH.xls]Berufshilfe'!$C$2:$C$5;5;2)>="40")*1);ZÄHLENWENN('[Statistik-BH.xls]Berufshilfe'!$G$2:$G$5;">="&74000))))*SUMMENPRODUKT((TEIL('[Statistik-BH.xls]Berufshilfe'!$C$2:$C$5;5;2)>="40")*1)}

Das Ergebnis erhalte stimmt aber hinten und vorne nicht.
Was mach ich falsch bzw. wo ist mein Denkfehler.
Vielen Dank für Eure Hilfe.
Liebe Grüße aus Würzburg
Guido Ludwig

Bild

Betrifft: AW: Zählenwenn in Kombi mit Summeprdukt
von: c0bRa
Geschrieben am: 25.04.2005 11:34:47
hallo...
probier mal:
=SUMMENPRODUKT('[Statistik-BH.xls]Berufshilfe'!$G$2:$G$5>=74000)*(TEIL('[Statistik-BH.xls]Berufshilfe'!$C$2:$C$5;6;2)*1>=40))

Rückmeldung nicht vergessen...
c0bRa
Zusammengesetzt ergeben die Rechtschreibfehler ein Geheimrezept, wie man aus Wasser Bier machen kann...
Bild

Betrifft: Danke, bringt leider Fehler in Formel (o.T.)
von: Guido
Geschrieben am: 25.04.2005 11:52:37

Bild

Betrifft: AW: Danke, bringt leider Fehler in Formel (o.T.)
von: c0bRa
Geschrieben am: 25.04.2005 12:00:42
kleiner klammerfresser ist wieder unterwegs... :)
=SUMMENPRODUKT(('[Statistik-BH.xls]Berufshilfe'!$G$2:$G$5>=74000)*(TEIL('[Statistik-BH.xls]Berufshilfe'!$C$2:$C$5;6;2)*1>=40))
sollte gehen ;)
Bild

Betrifft: AW: Zählenwenn in Kombi mit Summeprdukt
von: Martin Beck
Geschrieben am: 25.04.2005 11:45:56
Hallo Guido,
versuch's mal so (Blattbezug mußt Du noch anpassen):
=SUMME((G2:G5>=74000)*(WERT(TEIL(C2:C5;6;2))>40)*1)
Gruß
Martin Beck
Bild

Betrifft: AW: Zählenwenn in Kombi mit Summeprdukt
von: Danke, probiere ich mal aus (o.T.)
Geschrieben am: 25.04.2005 11:53:37

Bild

Betrifft: Danke an c0bRa und Martin, funzt beides (o.T.)
von: Guido
Geschrieben am: 26.04.2005 08:39:59

 Bild

Beiträge aus den Excel-Beispielen zum Thema "VBA-Code zum Ausblenden einer Excel-Mappe"