Brauche Hilfe zu Abfrage mit Index und 2 Kriterien

Bild

Betrifft: Brauche Hilfe zu Abfrage mit Index und 2 Kriterien von: Jutta N.
Geschrieben am: 01.03.2005 14:21:54

Hallo,

ich brings nicht hin.
Ich will die Stückzahlen von Tabelle1 in Tabelle2 einfügen. Das zweite Abfragekriterium steht aber in Tabelle2 in einer Zeile und nicht Spalte.

Muster:
https://www.herber.de/bbs/user/18979.xls

Gruß

Jutta

Bild


Betrifft: AW: Brauche Hilfe zu Abfrage mit Index und 2 Kriterien von: u_
Geschrieben am: 01.03.2005 14:46:50


=SUMMENPRODUKT((Tabelle1!$A$3:$A$14=$A2)*(Tabelle1!$B$3:$B$14=B$1)*(Tabelle1!$C$3:$C$14))


Bild


Betrifft: AW: Brauche Hilfe zu Abfrage mit Index und 2 Kriterien von: Jutta N.
Geschrieben am: 01.03.2005 15:15:18

Hallo U_,

da ist noch ein Wurm in der Formel. Schau dir mal das Ergebnis an:

https://www.herber.de/bbs/user/18980.xls
Beispiel:
3EF703B wird mehrmals in der Spalte "ES" ausgewiesen obwohl nur ein Wert für diese Spalte vorhanden ist.

Gruß

Jutta


Bild


Betrifft: AW: Brauche Hilfe zu Abfrage mit Index und 2 Krite von: Reinhard
Geschrieben am: 01.03.2005 15:49:50

Hi Jutta,
mir ist unklar was du möchtest, Formel ist okay.
Welche Werte sollen denn z.B. in B1:B14 ("ES") stehen? Liste die mal hier auf, ohne datei hochzuladen.
Gruß
Reinhard


Bild


Betrifft: AW: Brauche Hilfe zu Abfrage mit Index und 2 Krite von: c0bRa
Geschrieben am: 01.03.2005 15:56:53

ich glaub langsam, sie will auch noch die instanz berücksichtigen, in welcher des "ES" vorkommt... und dann wirds haarig.

sprich des 2. "ES" in der liste ist nicht glecih dem ersten "ES"... nur woher soll excel das dann wissen?


c0bRa


Bild


Betrifft: AW: Brauche Hilfe zu Abfrage mit Index und 2 Krite von: Jutta N.
Geschrieben am: 01.03.2005 16:05:47

Hallo c0bRa,

die Doppelten waren zuviel (zuviel Stress heute..)
Die Formel klappt prima.

Danke an alle.

Gruß

Jutta


Bild


Betrifft: AW: Brauche Hilfe zu Abfrage mit Index und 2 Krite von: Jutta N.
Geschrieben am: 01.03.2005 16:01:21

Hallo Roland,

tausendmal sorry, ich hatte in meinem Muster Doppelte drin.
Klappt natürlich. Vielen Dank !

Gruß

Jutta


Bild


Betrifft: AW: Brauche Hilfe zu Abfrage mit Index und 2 Krite von: o.T.
Geschrieben am: 01.03.2005 16:02:51

Habe aus versehen noch einmal den Haken bei "Frage noch offen " gesetzt.

Gruß

Jutta


Bild


Betrifft: AW: Brauche Hilfe zu Abfrage mit Index und 2 Kriterien von: heikoS
Geschrieben am: 01.03.2005 15:55:37

Hallo Jutta,

das liegt aber eher an Deinen Daten. Die Mat.-Nr. kommen in Spalte A mehrfach vor. Genauso das Land/Untergruppe in Zeile 1. Dann wird Dir das jeweilige Ergebnis natürlich mehrfach ausgewiesen. Die Formel arbeitet sauber.


Gruß Heiko


Bild


Betrifft: AW: Brauche Hilfe zu Abfrage mit Index und 2 Kriterien von: Jutta N.
Geschrieben am: 01.03.2005 16:03:56

Hallo Heiko,

Danke! Jetzt habe ich es auch gesehen.

Gruß

Jutta


Bild


Betrifft: AW: Brauche Hilfe zu Abfrage mit Index und 2 Kriterien von: heikoS
Geschrieben am: 01.03.2005 16:12:18

Hallo Jutta,

kein Problem - passiert halt, wenn man eine Bsp.-Datei erstellt.

Danke für die Rückmeldung.


Gruß Heiko


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Brauche Hilfe zu Abfrage mit Index und 2 Kriterien"