Microsoft Excel

Herbers Excel/VBA-Archiv

"Binnen"

    Betrifft: "Binnen" von: Martin
    Geschrieben am: 30.09.2003 15:31:26

    HI Forum

    Ich soll folgende Daten:
    3.4
    2.5
    1.3
    4.7
    usw.

    Einteilen in Kategorien von 0-2, 2-4, 4-6 usw., um so zu wissen wie viel Prozent 0-2, 2-4 usw. in Datensatz enthlten ist.
    Ich habe schon mal bepostet, aber da hat jemand was gepostet was nichts mit dem Thema zu tun hatte.

    THX für Hilfe

    Cu MaRtiN

      


    Betrifft: AW: "Binnen" von: Mimi
    Geschrieben am: 30.09.2003 15:36:08

    das könnte dir hier auch passieren :-)

    Ich verstehe die Frage auch nicht, tut mir leid!

    Was sollen das für Werte sein (Datum´s)?
    Und wie willst du das irgendwohin einteilen?

    Gruß
    Michael


      


    Betrifft: AW: "Binnen" von: Martin
    Geschrieben am: 30.09.2003 15:38:54

    das sind Windmesswerte! Und ich will einfach nur wissen, wie viele Werte in diesem Datensatz zwischen 0-2, 2-4 usw. sind. Da es leider 4600 Werte sind kann man es nicht von Hand machen ;o)... Ich hoffe ich habe mich besser ausgedrückt?!


      


    Betrifft: AW: "Binnen" von: mimi
    Geschrieben am: 30.09.2003 15:51:04

    ich höffe ich habe dich jetzt besser verstanden...

    "Summewenn" heißt die Formel.
    Sie berechnet die Summe, wenn die Kriterien (<> irgendwas)übereinstimmen.
    Mach dir eine Hilfsspalte mit "1" pro Wert un die läßt du dann summieren von der Formel.
    Benutze den Assistenten, der hilft die dabei!

    Gruß
    Michael


      


    Betrifft: AW: "Binnen" von: Martin
    Geschrieben am: 30.09.2003 15:53:14

    Es soll da eine englische Funktion geben, die soll "frequency" oder so heissen und die soll das können, aber ich habe nur DT XLS also gibt es die nicht...


      


    Betrifft: AW: "Binnen" von: mimi
    Geschrieben am: 30.09.2003 15:55:51

    kenne ich nicht!

    eins noch, dann muß ich heim....
    du hattest glaube ich 2 suchkriterien, dann mußt du "Summenprodukt" benutzen.
    Die kann man auch als Anzahl schreiben, dann bräöuchtst du die HIlfszeile nicht,
    das kann ich leider aber nicht!

    So, schönen Feierabend
    Michael


      


    Betrifft: AW: "Binnen" von: Frodi
    Geschrieben am: 30.09.2003 16:05:20


    Hallo,

    versuchs mal mit:

    =SUMMENPRODUKT((A1:A4000>0)*(A1:A4000<2))

    diese Formel zählt alle Werte zwischen 0 und 2!

    Gruß
    Frodi


      


    Betrifft: AW: "Binnen" von: mimi
    Geschrieben am: 30.09.2003 16:12:26

    mist zu spät :-)


      


    Betrifft: AW: "Binnen" von: Martin
    Geschrieben am: 30.09.2003 16:25:00

    HI Jungs /Mädels

    Danke für die Hilfe... Klappt spitze...

    THX

    Cu MaRtiN


      


    Betrifft: AW: "Binnen" von: Mimi
    Geschrieben am: 30.09.2003 16:11:53

    Ich noch mal:

    =SUMMENPRODUKT(($A$2:$A$239>0)*($A$2:$A$239<2))

    die Werte von dir stehen in diesem Bereich...
    das wäre die ANZAHL von Werten, die zwischen 0 und 2 liegen

    Ende


      


    Betrifft: AW: "Binnen" von: th.heinrich
    Geschrieben am: 30.09.2003 16:16:00

    hi Martin,

    schau Dir die FUNKTION HÄUFIGKEIT an.

    gruss thomas.

    ps. was soll der BETREFF "BINNEN"? leider nicht sehr aussagekraeftig.


      


    Betrifft: AW: "Binnen" von: Martin
    Geschrieben am: 30.09.2003 16:22:21

    "Binnen" so hat es meine englischer Prof hier genannt. Da dacht ich damit könnt Ihr Nerds was anfangen... ich teste mal...
    MaRtiN


      


    Betrifft: nachtrag von: th.heinrich
    Geschrieben am: 30.09.2003 16:24:40

    hallo Martin,

    also das musst Du mir jetzt erklaeren warum Du die loesung von Holger nicht anwendest.

    https://www.herber.de/forum/archiv/316to320/t316843.htm

    gruss thomas

    Du hast Ihm noch nicht einmal geantwortet :-(((((


      


    Betrifft: Gegendarstellung !!! von: Panicman
    Geschrieben am: 30.09.2003 16:21:26

    Hallo Martin,

    tut mir leid, wenn du meinen ersten Ansatz nicht verstanden hast.
    https://www.herber.de/forum/messages/316872.html
    Ich bin davon ausgegangen, daß "3.4" im deutschen XL ein Text ist,
    da eigentlich in Deutschland ein Komma üblich ist.

    tja, hab dich halt nicht besser verstanden.
    Die Glaskugel war heute beschlagen, wg. dem Nebel.

    Aber jetzt hast du ja andere (oder doch die gleichen) Lösungen.
    Du hättest aber auch einfach in dem alten Threat schreiben können,
    das du das nicht verstanden hast. Dann wäre warscheinlich dein Problem
    schon vor Stunden gelöst gewesen.

    Gruß
    Holger


      


    Betrifft: hallo Holger, meine rede ot. von: th.heinrich
    Geschrieben am: 30.09.2003 16:48:11

    .


      


    Betrifft: =HÄUFIGKEIT() oT von: Karl-Otto Reimann
    Geschrieben am: 30.09.2003 17:51:14

    .