Microsoft Excel

Herbers Excel/VBA-Archiv

Summenprodukt mit zwei Kriterien



Excel-Version: 10.0 (Office XP)

Betrifft: Summenprodukt mit zwei Kriterien
von: Gerhard
Geschrieben am: 29.05.2002 - 17:35:02

Hallo

habe 12 Tabellen in einer Mappe Jan-Dez alle gleich aufgebaut,
nun möchte ich in einer neuen Tabelle alle Werte die den zwei
Kriterien entsprechen erfassen.
Wie kann ich die Formel abändern dass alle 12 Tabellen erfasst werden.

=SUMMENPRODUKT((A1:A100="dcx")*(B1:B100=40)*C1:C100)

  

Re: Summenprodukt mit zwei Kriterien
von: Arnim
Geschrieben am: 29.05.2002 - 18:42:45

Hallo Gerhard,

m.E. geht es nur mit einer Summierung über alle Tabellenblätter.
Du müßtest in jedem Tabellenblatt Deine Formel in eine bestimmte Zelle , z.B. D1, schreiben und als Zusammenfassung die Formel
=SUMME(Tabelle1:Tabelle12!D1)

Vielleicht weiß aber jemand eine bessere Lösung!

Gruß Arnim

  

Re: Summenprodukt mit zwei Kriterien
von: Gerhard
Geschrieben am: 30.05.2002 - 13:30:08

Hallo Armin,

danke für die schnelle Info.

Vielleicht weiß doch noch jemand eine bessere Lösung
kann auch in Form eines Makros sein.

Gerhard


 

Beiträge aus den Excel-Beispielen zum Thema "Summenprodukt mit zwei Kriterien "