Herbers Excel-Forum - das Archiv

Index Matrix



Excel-Version: 9.0 (Office 2000)
nach unten

Betrifft: Index Matrix
von: Markus Hegner


Geschrieben am: 13.05.2002 - 16:45:11

Hallo,

ich möchte folgendes Problem lösen:

Tabelle 1:

Spalte A:
Nummernwert (400 Zeilen insgesamt)

Spalte B:
ERGEBNIS aus Tabelle 2

Tabelle 2:

Spalte A: Nummernwert (400 Zeilen insgesamt) identisch mit Tabelle 1!

Spalte B: Erklärung zum Nummernwert

Die Erklärung zum Nummernwerte soll nun bei Übereinstimmung in Tabelle 1, Spalte B übernommen werden.

Kann ich dieses Problem mit Index lösen und wenn ja wie?

Grüße

Markus


nach oben   nach unten

Nachfrage
von: mathias r.

Geschrieben am: 13.05.2002 - 16:51:28

Einerseits schreibst du Spalte A ist n Tabelle1 und Tabelle2 identisch , andererseits "die Erklärung soll bei Übereinstimmung übernommen werden"?

nach oben   nach unten

Re: Nachfrage
von: Markus Hegner

Geschrieben am: 13.05.2002 - 17:45:27

Hallo,

in der zweiten Tabelle befindet sich der Zahlenwert und die Erklärung. In der ersten Tabelle nur der Zahlenwert. Die Erklärung soll nun übernommen werden in die erste Tabelle.

Gruß

Markus


nach oben   nach unten

Re: Nachfrage
von: mathias r.


Geschrieben am: 13.05.2002 - 18:23:17

ALso wenn die Zellen Tabelle1/Tabelle2 in der gleichen Zeile nur MANCHMAL identisch sind dann:

=WENN(A1=Tabelle2!A1;Tabelle2!B1;"")

wenn die REIHENFOLGE der Zeilen in Tabelle2 anders ist als in Tabelle1, dann:
=SVERWEIS(A1;Tabelle2!$A$1:$B$3;2;FALSCH)

Die Formeln sind jeweils für die erste Zeile und können dann "heruntergezogen werden" (Autoausfüllen)

 nach oben

Excel-Beispiele zum Thema "Index Matrix"
Entfernungsmatrix listen Ausgabe einer benutzerdefinierten Funktion in Matrixformel
Werte aus Zellbereich in eine Matrix übernehmen und auslesen Portokosten aus einer Gewichts-/Gebietsmatrix errechnen
Matrix in UserForm-ListBox einlesen SVERWEIS-, WVERWEIS- und Matrixformel-Beispiele
Anzahl nach 2 Kriterien ermitteln mit DB-Funktion und MatrixFormel Werte aus Matrix in zweitem Blatt auflisten
Zweidimensionale Matrix mit der SVERWEIS-Funktion durchsuchen Daten in Matrix indizieren